[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn st -u regression with 1.1.x servers

From: SteveKing <steveking_at_gmx.ch>
Date: 2005-07-16 18:23:51 CEST

Ben Collins-Sussman wrote:

> Oh my, how embarrassing. I can reproduce by running 'svn st -u'
> against any svn repository on tigris.org (which is running svn 1.1).
>
> svn 1.2 is running svn_ra_get_locks() during 'svn st -u'. mod_dav_svn
> is throws SVN_ERR_UNSUPPORTED_FEATURE when it receives the unfamiliar
> REPORT request (rather than RA_NOT_IMPLEMENTED, which is what svnserve
> returns.) Does the following patch work for you? It does for me.

Currently doing a rebuild. It will take a while until it's finished.
I'll report back when it's done.

> I think this bug alone might justify an svn 1.2.2 release.

Since 'svn st -u' is an important and often used feature, I agree.
(I'm just wondering why noone else noticed this before - maybe because
all projects were already using an svn 1.2 server?)

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest Interface to (Sub)Version Control
    /_/   \_\     http://tortoisesvn.tigris.org
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Jul 16 18:25:12 2005

This is an archived mail posted to the Subversion Dev mailing list.