Ben Collins-Sussman <sussman@collab.net> writes:
> +/**
> + * @defgroup svn_repos_logging Repository logging subsystem
> + * @{
> + *
> + * @since New in 1.3.
> + */
> +
> +/** The different "levels" of messages that can go into a repository's
> + errorlog. */
> +typedef enum
> +{
> + /** A real error happened */
> + svn_repos_loglevel_error = 1,
> +
> + /** No error, but something that might be of concern */
> + svn_repos_loglevel_warning = 5,
> +
> + /** Message only interesting to svn developers */
> + svn_repos_loglevel_debug = 10
> +
> +} svn_repos_loglevel_t;
This enum controls what goes in the *error* log, according to its doc
string. So perhaps it should be called 'svn_repos_errorlog_level_t',
so as not to imply that it affects non-error logging?
Also, I agree with Martin Furter: if you're going to spread 'em out,
spread 'em out wide (i.e., 100, 500, 1000) :-).
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jul 15 21:23:40 2005