[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r15287 - in trunk/subversion: libsvn_ra_svn

From: Greg Hudson <ghudson_at_MIT.EDU>
Date: 2005-07-08 07:20:33 CEST

On Thu, 2005-07-07 at 23:01 -0500, kfogel@collab.net wrote:
> I had never noticed this about ra_svn (or if I did, I wish I had said
> something earlier). I like declaring variables in the block in which
> they are used. It makes the code more readable, IMHO. As far as I
> know, the rest of Subversion does this, albeit not with perfect
> consistency.

> Are you dead set against it? If so, why?

No, I'm not dead-set against it. I think interior declarations break up
the flow of code.

> I'm not proposing that we change all of ra_svn's style now -- that's
> not worth messing up blame information over. But I'd like to at least
> go with interior variables in new code; I even think that justifies
> inconsistency with the old code.

While I often wish ra_svn and ra_dav used the same style as the rest of
the code base, I don't think the inconsistency in ra_svn code is worth
it here.

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jul 8 07:22:00 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.