[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r15287 - in trunk/subversion: libsvn_ra_svn

From: <kfogel_at_collab.net>
Date: 2005-07-08 06:01:49 CEST

Greg Hudson <ghudson@MIT.EDU> writes:
> Moreover, it is inconsistent with the style of ra_svn to use any
> interior variable declarations. Please declare all variables at the top
> of each function.

Hmm, can we talk about this first?

I had never noticed this about ra_svn (or if I did, I wish I had said
something earlier). I like declaring variables in the block in which
they are used. It makes the code more readable, IMHO. As far as I
know, the rest of Subversion does this, albeit not with perfect

Are you dead set against it? If so, why?

I'm not proposing that we change all of ra_svn's style now -- that's
not worth messing up blame information over. But I'd like to at least
go with interior variables in new code; I even think that justifies
inconsistency with the old code.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri Jul 8 06:50:02 2005

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.