[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: r15177 - trunk/subversion/bindings/swig/ruby/svn

From: Jani Averbach <jaa_at_jaa.iki.fi>
Date: 2005-06-29 03:46:38 CEST

On 2005-06-29 10:29+0900, Kouhei Sutou wrote:
> Jani Averbach wrote:
>
> > Here is a list what might be special in my system:
> >
> > - apr and apr-util has been compiled with memory debugging enabled:
> > "--enable-pool-debug=yes"
> > - I have hardware noexec stack in use
> > - The system is 64bit
>
> I tried the following environment but I can't reproduce.
>
> - apr and apr-util are compiled with --enable-pool-debug=yes
> - apr ver.: http://svn.apache.org/repos/asf/apr/apr/branches/0.9.x/
> - apr-util ver.: http://svn.apache.org/repos/asf/apr/apr-util/branches/0.9.x/
> - apr configure options: --enable-pool-debug=yes --disable-threads
> - apr-util configure options: --enable-pool-debug=yes
> - The system is 64 bit.
> - % uname -mrs # => FreeBSD 5.4-RELEASE-p2 amd64

*Shurg* I really don't know.

If you came up any others idea how to verify that my setup is ok,
please let me know.

> I don't know "hardware noexec stack", so I can't use it.

It is hardware level protection that stack isn't executable, I think
that FreeBSD uses it also, but I am not sure.
 
> By the way, swig-rb test result has not been sent to svn-breakage
> list yesterday. Jani, do you know what's happen?

The last run was no-op (svn trunk r15181: NOOP...) because there
weren't any code changes between this revision and the latest tested
(15178:15181). So the system skipped that test run.

BR, Jani

-- 
Jani Averbach
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jun 29 03:47:28 2005

This is an archived mail posted to the Subversion Dev mailing list.