[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index


From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2005-04-05 03:38:23 CEST

On Apr 4, 2005, at 2:36 PM, Julian Foad wrote:
> Aha! I have just seen that "SVN_ERR_FS_PATH_LOCKED" is tested by the
> macro "SVN_ERR_IS_LOCK_ERROR", and therefore perhaps is intended only
> to mean, "You can't lock this path because it is already locked". If
> that's the case, may we rename it to "SVN_ERR_FS_PATH_ALREADY_LOCKED"?
> Or at least document it as such.

Yes, I think that's exactly the difference between the two error codes.

> (By the way, I am looking at this from the point of view that
> everything - including each error code - should have an inherent
> meaning that is known and documented, rather than its meaning just
> being considered to be "whatever the code that currently uses it wants
> it to mean".)

If this is your goal, I think you have a loooooong road ahead of you,
looking at svn_error_codes.h. :-/

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Apr 5 03:41:03 2005

This is an archived mail posted to the Subversion Dev mailing list.