[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Review of APIs new in 1.2

From: Julian Foad <julianfoad_at_btopenworld.com>
Date: 2005-04-04 22:50:42 CEST

Update as of r13909.

The items not mentioned here have already been resolved, and here I wrap up the
loose ends:

Julian Foad wrote:
> svn_client_move2
> Bug: parameter "force" needs a better name.

I have at last dug into history to read the deleted "notes/TODO-1.2-foad.txt"
file and seen the comments in there - including that it was difficult to find a
name for this last "force" parameter. I might have a go at it; if not, it will
just have to stay until another time.

> Need to clarify the difference between these, or merge them.

I've started a separate thread about this.

> Someone raised a concern about whether these belong in svn_error.h or
> are too specialised to be there.

They can stay.

> SVN_ERR_* (in svn_error_codes.h)
> Bug (maybe): The comments should be Doxygen comments (starting "/**").

I'm leaving that as I don't feel strongly enough about it.

> svn_fs_unlock
> Slight contradiction.

That's not worth bothering with. It's clear enough.

> (all public headers)
> Use of "true" and "false" versus "@c TRUE" etc. I think we should say
> "true" and "false".
> Use of "<pre>", "note", "warning", "@note", "@warning", etc.
> Use of "<tt>" versus "@c".
> Use of "@a" to refer to args of a different function.

Those, and more, are all aspects of our Doxygen usage policy which I will
address in a separate thread.

> svn_ctype.h
> svn_ra_reporter2_t
> svn_wc_diff_callbacks2_t
> Not reviewed.

If I review those I'll do so in a separate thread.

Therefore I consider this thread wrapped up. Thanks for listening.

- Julian

To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Apr 4 22:51:55 2005

This is an archived mail posted to the Subversion Dev mailing list.