[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svnlook log returns ?\xxx

From: Peter Lfgren <list_at_loftux.se>
Date: 2004-10-04 15:29:49 CEST

Hi,
(Sorry if this message appears twice, first send was with an account that
wasn't subscribed. Dont know how that is handled)

Just upgraded to Subversion 1.1.0 (r11180) on Windows (prebuilt binaries
from download area) and noticed that svnlook doesn't return swedish
characters as expected, svn log does.

Sample output:
C:\>svnlook log C:\subversion\repository\testrepo Gjort ?\132ndringar
?\143?\142?\153 ?\134?\132?\148 N?\132sta rad ?\143?\142?\153
?\134?\132?\148

C:\>svn log -r14 http://localhost/svn/testrepo (
------------------------------------------------------------------------
r14 | pelfg | 2004-10-04 12:50:13 +0200 (m, 04 okt 2004) | 2 lines

Gjort ndringar
Nsta rad

(The above text from svn log has the correct characters with umlauts, if not
your mail program doesn't support them)

Running on Windows XP (Sp2), with apache 2.0.52 (upgraded from 2.0.50 to see
if this was part fo the problem).

APR_ICONV_PATH = C:\Program Files\Subversion\iconv

All language and regional options set to Swedish

I do have TortoiseSVN 1.1.0 installed on the same machine. R

Did work before the upgrade, latest version used before upgrade 1.0.6

There was a previous discussion on a svnlook issue
http://www.contactor.se/~dast/svn/archive-2004-09/0996.shtml
That eventually was solved with r11172. Might be related to this.

Hope this is enough info for someone to start looking att this.

Regards,

Peter Lfgren

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Mon Oct 4 15:30:19 2004

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.