[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] svn_load_dirs update #2

From: Blair Zajac <blair_at_orcaware.com>
Date: 2004-01-17 21:30:58 CET

Peter Gervai wrote:
>
> On Fri, Jan 16, 2004 at 08:16:04PM -0800, Blair Zajac wrote:
>
> > I committed part of this patch minus the modifications to the
> > get_yes_or_no subroutine in revision 8357.
> >
> > I think I'd rather have some other way of indicating a yes to all
> > answer. Part of the issue is that you can say 'a' to the very
> > first question that the program asks and it'll answer yes from
> > then on until $yes_to_all is reset to 0.
> >
> > I would prefer the following:
> >
> > 1) Rename get_yes_or_no to something like get_answer.
> > 2) Have get_answer take a list of valid responses and
> > say the default response, and a mapping from typed
> > response to the value that get_answer should return.
>
> See patch. I tried to follow the coding style, but it is definitely not
> something I like. :-) I hope I got it all right.

Peter,

Thanks. Committed in revision 8364.

I changed the default answer for the svn mkdir at the beginning to yes,
otherwise the script won't do anything.

Best,
Blair

-- 
Blair Zajac <blair@orcaware.com>
Plots of your system's performance - http://www.orcaware.com/orca/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Jan 17 21:31:34 2004

This is an archived mail posted to the Subversion Dev mailing list.