[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: PATCH: Stop defining identifiers in APR's name space

From: <kfogel_at_collab.net>
Date: 2003-12-19 23:22:57 CET

Julian Foad <julianfoad@btopenworld.com> writes:
> Ah, yes. Acually if we're not absolutely sure they will go into
> APR, it's wrong to have "APR" in their names, so that should just be
> "svn__foo" or, in svn_sorts.h, "svn_sort__foo".

No, in general it's okay, just don't *begin* with "apr".

For example, we'd be perfectly within our rights (if not our senses)
to name a function "svn_wrap_apr_file_remove".

> So I think we want:
> svn_sort__hash
> svn_sort__item_t
> Yes?

Yes, and document. Though if Greg's right about these never making it
into APR, then we don't need the caution.

Don't know now, but we can decide later, since ...

> Unfortunately I will be pretty much off-line from tomorrow until
> about 6th January, so I probably won't have time to do this now.
> Anyone please feel free to continue this.

No problem. Can you attach your latest patch to the issue?


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Dec 20 00:12:52 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.