[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: CHANGES: Suggestion

From: Tobias Ringstrom <tobias_at_ringstrom.mine.nu>
Date: 2003-11-27 17:18:57 CET

Jostein Chr. Andersen wrote:
> Hi,
>
> This is my suggestion for the 0.34.0 update in CHANGES. Please, give me
> feedback :-)
>
> -------------------------------------------------
> Version 0.34.0 (released 3 December 2003, revision r7859)

I know this is in the instruction, but I really don't see why the
revision number would be interesting. The only reason it's still there
is that it was needed a long time ago when Subversion did not support
branches. The URL below is the only info you need to check out the release.

> http://svn.collab.net/repos/svn/tags/0.34.0
>
> #####################################################################
> ## WARNING WARNING WARNING WARNING WARNING WARNING WARNING ##
> #####################################################################
> ## ##
> ## This release makes an incompatible change to the Subversion ##
> ## repository filesystem schema. Repositories created with ##
> ## Subversion code prior to this release will unable to operate ##
> ## with this new code. To maintain the ability to use said ##
> ## repositories, you must use a version 'svnadmin dump' prior to ##
> ## this change to dump your repository to a dumpfile, then use ##
> ## this new Subversion code to create, and load your dumpfile ##
> ## a new repository using 'svnadmin load'. And don't forget to ##
> ## copy over any custom configuration/hooks from the old to the ##
> ## new repository. ##
> ## ##
> #####################################################################
>
> Please see the notes/repository_upgrade_HOWTO document located for
> documentation on migrating pre-.34 repos to revision .34.
>
> Also located here:
> http://svn.collab.net/repos/svn/trunk/notes/repos_upgrade_HOWTO

Maybe you can put this inside the nice box above?

> User-visible changes:
> * fs schema change (#1578, #1595) **NOTE: repos dump/load cycle
> required!**
> * berkeley-4.2.50 are now the recommended Berkeley version

Maybe "Berkeley DB 4.2.50 is now the recommended version" or something
similar would be better.

> * Fix: 'svn status' thought replaced items were unversioned (#1609)
> * Big SSL server cert error prompt improvement (r7849)

Drop the "Big". It wasn't that big. :-)

I haven't checked if all fixed isses are mentioned, but it looks like a
very nice first CHANGES file. Well done, Jostein!

/Tobias

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Nov 27 17:20:38 2003

This is an archived mail posted to the Subversion Dev mailing list.