[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 7241 - branches/issue-1499-dev/subversion/libsvn_fs

From: Greg Stein <gstein_at_lyra.org>
Date: 2003-10-02 09:59:39 CEST

On Mon, Sep 29, 2003 at 12:09:32PM -0500, cmpilato@tigris.org wrote:
> Author: cmpilato
> Date: Mon Sep 29 12:09:31 2003
> New Revision: 7241
> Modified:
> branches/issue-1499-dev/subversion/libsvn_fs/trail.c
> branches/issue-1499-dev/subversion/libsvn_fs/trail.h
> Log:
> Redo the optional-transaction change, but this time use two different
> functions instead of exposing a boolean "use a transaction" flag. I'm
> hoping that this is what Greg Stein was talking about when he made the
> suggestion that led me this way.

Yes, sir! Thanks!

The basic point is that a parameter to the function was effectively
providing you with two different semantics. In my mind, that means you're
actually talking about two functions, so make that explicit. For a reader,
it is generally easier to figure out what is up based on the function name
than needing to visit the header to see what that true/false parameter is
all about.

I've had some of the same feelings around all those "control" flags on
dir_delta. When you spun out the new replay function... very nice. That
refactor/flag-issue was essentially an analogue to this "retry" stuff.


Greg Stein, http://www.lyra.org/
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Thu Oct 2 10:03:56 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.