[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Enhancing and possibly renaming svnadmin archive command

From: <cmpilato_at_collab.net>
Date: 2003-08-05 21:32:33 CEST

Vladimir Berezniker <vmpn@tigris.org> writes:

> A). Add two new parameters to svn_fs_berkeley_archive to look as follows:
>
> /** Set @a *logfiles to array of <tt>const char *</tt> logfile paths
> * of Berkeley DB-based Subversion filesystem.

This function is misnamed. It should be svn_fs_berkeley_logfiles().

> *
> * @a absolute_paths specifies format of the paths:
> * TRUE - Paths are to be absolute
> * FALSE - Paths are to be relative to the Berkeley DB logs directory.

I still say it's kinda silly to have a parameter to toggle this since
we can always run over a list of relative paths and convert them to
absolute ones. Nevermind that Berkeley's log_archive() function would
be the one doing this work for us anyway -- from an API point of view,
it's just noise.

> *
> * @a all_log_files specifies which logs to include in the list:
> * TRUE - All logs are included
> * FALSE - Only unused logs are included

I'd rather make the default answer contain all the log files, and then
have a parameter named 'ignore_unused' to toggle that behavior.

> B) Modify svnadmin's main.c to allow expose the new API to the end user.

Sure.

> A). Name of the "archive" command.
>
> As Michael Wood pointed out that "archive" is not the best name

Right. How about "svnadmin lslogs [--ignore-unused]" ?

> * If command is renamed does svn_fs_berkeley_archive get renamed
> as well or a new function is created (e.g. svn_fs_berkeley_loglist)
> and svn_fs_berkeley_archive calls the new function so that any
> existing code works without a change.?

Yes. As I noted above, the function is misnamed. (And, IMO, so is
the Berkeley function and utility).

> B). Need for absolute_paths parameter.
>
> cmpilato@collab.net said: "I don't really see the need to have
> the abs-vs.-rel path parameter", referring to absolute_paths
> parameter.
> http://article.gmane.org/gmane.comp.version-control.subversion.devel/31725

See above.

> * Given that I also want to submit a patch for "svnadmin copy"
> (hot copy) command that will need log file names only, is that a
> reason enough to keep that parameter? You can read about why I wish to
> compare log files at
> http://article.gmane.org/gmane.comp.version-control.subversion.devel/31740

Make the function return just the basename (which is how I understand
BDB's log_archive() function to work), and convert to absolute path
when you need to.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Aug 5 21:34:49 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.