[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 5949 - in trunk: doc/book/book subversion/clients/cmdline subversion/include subversion/libsvn_wc

From: Greg Stein <gstein_at_lyra.org>
Date: 2003-05-16 03:24:37 CEST

On Thu, May 15, 2003 at 11:20:59AM -0500, sussman@tigris.org wrote:
> Mauve Bikeshed: show a "!" for incomplete dirs, just like missing
> items, so that users realize that 'svn up' needs to be run.
> [ People are still arguming, but let's try this out for a little
> while. If we come up with a different consensus, or if this causes
> disaster/confusion, we can always change it. ]

I think Jay's points about overloading this are *very* good. We should
choose a different symbol.

I have no opinion on *which* symbol, but overloading is Badness, IMO.

> * svn_wc.h (enum svn_wc_status_kind): new 'incomplete' status enum.

To me, the fact that we can best model "incomplete" as a status leads me to
think it is a first-column marker, rather than sharing a column with the
"switched" state as Brane suggested.

> * book/ch03.xml, ch08.xml: update book's description of '!', and what
> to do when you see it.

I don't think you should have done this, given the discussion. Assuming we
remove the overloading of the symbol, this stuff will completely change.


Greg Stein, http://www.lyra.org/
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Fri May 16 03:22:54 2003

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.