[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 5001 - in trunk/subversion: include libsvn_wc libsvn_client libsvn_delta

From: Garrett Rooney <rooneg_at_electricjellyfish.net>
Date: 2003-02-22 18:11:51 CET

On Saturday, February 22, 2003, at 10:40 AM, Greg Hudson wrote:

> On Sat, 2003-02-22 at 09:41, Philip Martin wrote:
>> I don't think svn_types.h is correct. The "cancellation" editor
>> doesn't really have anything to do with cancellation, it's simply an
>> editor that calls a given function before dispatching to another
>> editor. If you renamed it the "prefix" editor it would live quite
>> naturally in svn_delta.h. It could even be generalised to have both
>> prefix and suffix functions.
> I'm not sure if making it more abstract will make our code clearer or
> not. It's an interesting idea, though.
> But it seems wrong to, having accepted the argument that the
> cancellation editor should live in libsvn_delta, exclude it from
> svn_delta.h and move it to a header file which doesn't even know the
> nceessary types (svn_delta_editor_t).

but the cancellation editor is in svn_delta.h right now. the only
thing left in svn_cancel.h is the typedef for svn_cancel_func_t, that's
what greg is proposing we move to svn_types.h.

as for making it more generic, i agree with greg h, it seems like it'll
just make the code less clear. right now it's painfully obvious from
the function name that we're wrapping the editor for cancellation
purposes, if we make it into svn_delta_get_prefix_editor, it's much
less clear.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Feb 22 18:12:35 2003

This is an archived mail posted to the Subversion Dev mailing list.