[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVNSERVE Tests Failing

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2003-02-01 23:47:23 CET

Eric Gillespie <epg@pretzelnet.org> writes:
> Again, am i missing something? Please tell me this hasn't been
> intentionally broken since Wednesday.

"This hasn't been intentionally broken since Wednesday."

There. Happy?

It has, however, been *unintentially* broken since Wednesday. Please
don't use such needlessly accusatory phrasing -- what do you gain by
it?

Anyone can write a bug (heck, I can even write more than one). But no
one here intentionally breaks code, at least without announcing it
first and waiting to hear what others say.

This bug is my fault. I should have tested more carefully (like, at
least ran some subset of the tests over ra_svn), and I didn't. My
apologies; I'll change the way I test, so this is less likely to
happen in the future.

However, as someone who recently submitted a patch that *didn't even
compile*, Eric, I think you could be a little less rancorous in
pointing out breakage. After I wasted my own time discovering that
your patch didn't build, I don't recall casting doubts on your
intentions in my rather amicable followups.

-Karl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sun Feb 2 00:16:55 2003

This is an archived mail posted to the Subversion Dev mailing list.