[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn commit: rev 4283 - trunk

From: Greg Stein <gstein_at_lyra.org>
Date: 2003-01-08 01:58:31 CET

On Wed, Jan 08, 2003 at 01:44:53AM +0100, Branko Cibej wrote:
> Greg Stein wrote:
> >On Tue, Jan 07, 2003 at 12:29:52PM -0600, brane@tigris.org wrote:
>...
> >>* INSTALL: Add a note about needin libtool 1.4.3 on Solaris.
> >
> >Euh... why don't we just change buildcheck.sh? Developers who download onto
> >Solaris and run autogen.sh will get trapped up properly, and people who roll
> >tarballs will use the correct version.
>...
> Do you mean to require 1.4.3 everywhere, or just on Solaris? I have the
> second solution done in build/buildcheck.sh, _but_ it means that
> tarballs have to be created with libtool 1.4.3, so that Solaris people
> can use them to build Subversion. I'd rather not make 1.4.3 a
> requirement everywhere, though.

Everywhere, yes, for the tarball situation.

I believe that MacOS X also needs libtool 1.4.3.

Hmm. Is the 1.4.3 requirement onerous for the developers? If that is the
case, then maybe we can change the 'dist.sh' script. We could make it so
that just the person rolling the release needs 1.4.3. Either encode that
into dist.sh or pass a parameter to autogen.sh (say, --release) which can
then be passed to buildcheck.sh to make it perform a more strict check.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Wed Jan 8 01:57:30 2003

This is an archived mail posted to the Subversion Dev mailing list.