[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: proposal to add apr_check_dir_empty() to APR

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2002-07-02 23:00:01 CEST

"William A. Rowe, Jr." <wrowe@rowe-clan.net> writes:
> One, the name sucks... perhaps apr_dir_is_empty()? Keep it named with the
> other apr_dir_ family members and our general schema. We have to work hard
> on consistency so we avoid symbol renames of newly created functions.

I've changed it to apr_dir_is_empty() in the Subversion sources, so it
will be that name when we port it over to APR.

> Other than that, I would _NOT_ assume all first two entries are "."/"..", but
> if you make that an explicit string test, I'd be +1.

Fixed now.

> Also, APR_EGENERAL seems a bit vague, how about APR_EEXISTS?

We should either make a new status code explicitly for this, or return
via an int* parameter. Personally I think the int* solution is
cleaner: the function should return an error status iff something went
wrong, and use an entirely separate channel for returning the answer.

Would anyone object to this solution?


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue Jul 2 23:09:59 2002

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.