[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [Issue 699] Changed - Dependency on XML parser not in INSTALL

From: Karl Fogel <kfogel_at_newton.ch.collab.net>
Date: 2002-05-07 16:31:22 CEST

Joe Orton <joe@manyfish.co.uk> writes:
> I can't reproduce this by removing all my system's XML parser devel
> packages: the r1868 tarball configures and builds correctly. apr-util
> doesn't find an installed expat, so it and neon both arrange to use the
> bundled copy of expat in apr-util.
>
> Karl, I'd guess the failure you are getting is a variant of the problem
> Martin found: apr-util is still detecting an installed copy of expat
> somewhere, but neon isn't: the apr-util configure output should reveal
> all.

Thanks for this excellent feedback, Joe. I'll give it a try when I
get home (that's the box that got "xml-cleaned", at least in theory).

> (The fact that neon is searching for an XML parser via xml2-config etc
> on your system means that the neon configure script was *not* passed the
> --with-expat=... flag: that should only happen when apr-util *does* find
> an installed copy of expat somewhere.)

Gotcha.

-Karl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Tue May 7 16:31:24 2002

This is an archived mail posted to the Subversion Dev mailing list.