[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

plan of action (was: Re: svn_kstring_t)

From: Greg Stein <gstein_at_lyra.org>
Date: 2001-06-07 23:53:44 CEST

On Thu, Jun 07, 2001 at 02:33:47PM -0700, Daniel Rall wrote:
> Greg Stein <gstein@lyra.org> writes:
>
> > On Wed, Jun 06, 2001 at 05:01:24PM -0400, Greg Hudson wrote:
> > > Some notes:
> > >
> > > "string" (for constant counted string) and "stringbuf" (for modifiable
> > > counted string) are more intuitive names than "kstring" and "string".
> >
> > Agreed. Unfortunately, I'm not sure if we could pull off this name change
> > since svn_string_t means something quite different. (I think the problem
> > mostly from the human angle of changing the semantics of the "svn_string_t"
> > which is in their brains)
> >
> > I'm +1 on your suggested naming. Thoughts from others?
>
> Both my experience with the Java language and with other C APIs lead
> me to agree that putting "buf[fer]" into the name of the expandable
> string is much more intuitive.

Okay... make sure everything is checked in before you leave tonite. Or
you'll be in merge hell tomorrow :-)

I'm going to make a mother-commit to s/svn_string_t/svn_stringbuf_t/ across
our whole code repository.

We'll let that shake out, then I'll start introducing svn_string_t (the name
for what I called svn_kstring_t). The first place I'll be starting is with
the FS library so that I can get good bindings around that sucker.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:31 2006

This is an archived mail posted to the Subversion Dev mailing list.