[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn_kstring_t

From: Daniel Rall <dlr_at_finemaltcoding.com>
Date: 2001-06-07 23:33:47 CEST

Greg Stein <gstein@lyra.org> writes:

> On Wed, Jun 06, 2001 at 05:01:24PM -0400, Greg Hudson wrote:
> > Some notes:
> >
> > "string" (for constant counted string) and "stringbuf" (for modifiable
> > counted string) are more intuitive names than "kstring" and "string".
> Agreed. Unfortunately, I'm not sure if we could pull off this name change
> since svn_string_t means something quite different. (I think the problem
> mostly from the human angle of changing the semantics of the "svn_string_t"
> which is in their brains)
> I'm +1 on your suggested naming. Thoughts from others?

Both my experience with the Java language and with other C APIs lead
me to agree that putting "buf[fer]" into the name of the expandable
string is much more intuitive.


To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org
Received on Sat Oct 21 14:36:31 2006

This is an archived mail posted to the Subversion Dev mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.