Jim Blandy wrote:
> The code looks good so far.
> It's fine with me to move svn_tdelta__winfo_t's ops_space into
> svn_delta_window_t. That field is useful to anyone wanting to operate
> on windows, which seems like something lots of code might need.
That'd be better, yes.
> Whenever I'm working with an array which might have more space
> allocated than used, I use `num_' to indicate the number of elements
> actually in use, and `_size' to indicate the allocated size (to
> suggest `sizeof'). If that convention appeals to you, you could call
> the field ops_size. But maybe num_ vs. _size is a weak distinction,
> making a poor convention.
I try to avoid using "size" for arrays when I mean length. Sometimes I
use _count and _capacity. Anyway, you're the author of the interface,
so I'll adapt to your style.
> I believe that svn_tdelta__winfo_t's data_offset is always equal to
> the window's new->len. If you eliminate that variable, you can get
> rid of svn_tdelta__winfo_t altogether. That would simplify your code
Indeed it is, but that would mean exposing the implementation details
of svn_string_t. If that's O.K., I'll do that an remove svn_tdelta__winfo_t.
> a bit. But eventually you'll have hash tables and other state anyway,
> so it may not be important.
In fact, I already _do_ have hash tables and other state ...
I've just now finished the core vdelta driver, along with the dumb
windowing method. I need to clean up the code a bit, so I'll have a
patch ready sometime tomorrow.
Then I'm off for a week.
> I sense that you have a lispy background. :)
Not really. I first saw this kind of syntax a long time ago when
I was playing around with TeX's virtual font descriptions, and hadn't
even heard of lisp. Sorry to disappoint you :-)
(Today, of course, I regularly hack at my .emacs file).
Branko Čibej <firstname.lastname@example.org>
HERMES SoftLab, Litijska 51, 1000 Ljubljana, Slovenia
voice: (+386 1) 586 53 49 fax: (+386 1) 586 52 70
Received on Sat Oct 21 14:36:06 2006