The code looks good so far.
It's fine with me to move svn_tdelta__winfo_t's ops_space into
svn_delta_window_t. That field is useful to anyone wanting to operate
on windows, which seems like something lots of code might need.
Whenever I'm working with an array which might have more space
allocated than used, I use `num_' to indicate the number of elements
actually in use, and `_size' to indicate the allocated size (to
suggest `sizeof'). If that convention appeals to you, you could call
the field ops_size. But maybe num_ vs. _size is a weak distinction,
making a poor convention.
I believe that svn_tdelta__winfo_t's data_offset is always equal to
the window's new->len. If you eliminate that variable, you can get
rid of svn_tdelta__winfo_t altogether. That would simplify your code
a bit. But eventually you'll have hash tables and other state anyway,
so it may not be important.
I sense that you have a lispy background. :)
Received on Sat Oct 21 14:36:06 2006