Re: Common name for transaction and revision object
From: Ryan Schmidt <subversion-2010b_at_ryandesign.com>
Date: Wed, 28 Apr 2010 16:38:41 -0500
On Apr 28, 2010, at 10:03, Blair Zajac wrote:
> If you look at the svn_fs.h API, they are both referred to as revision roots. svn_fs_revision_root() and svn_fs_txn_root() both return a svn_fs_root_t * object.
That does not sound like they're both being referred to as "revision roots"; that sounds like they're both being referred to as "roots".
If you're just looking to name a variable, you can call it RevisionOrTransaction.
This is an archived mail posted to the Subversion Users mailing list.