[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Question on client lib compatibility

From: Goetz Reyher <greyher_at_adobe.com>
Date: Tue, 5 Aug 2008 18:03:11 +0200

Hi all,

I've got a question concerning the backwards compatibility of newer
versions of the SVN client libs. As documented per http://subversion.tigris.org/svn_1.5_releasenotes.html
, the working copies are converted automatically to the newest
versions. Say you've worked using a 1.4 client, and touch the local
copies with a 1.5 client now, they get upgraded automatically (ie.
without a warning). However, this is not true for the repositores. So
one may be able to sync back to the older version of the repository
(1.4 in the ex.) to become client compatible again.

My question now is if you may already know if the same may occur with
the next release of the client libs, ie. 1.6 vs. 1.5? My guess is, yes
it could be, and we would have to take it into account. Is that the
correct notion?

Thanks a lot.

Sincerely,

Goetz

Goetz Reyher

Engineering Manager
Adobe Systems Engineering GmbH
Große Elbstraße 27
22767 Hamburg

Registergericht: Hamburg HRB 745 37
Geschäftsführer: Thomas Mührke
Received on 2008-08-05 20:07:27 CEST

This is an archived mail posted to the Subversion Users mailing list.