On Sep 30, 2009, at 1:46 PM, Stefan Sperling wrote:
> On Wed, Sep 30, 2009 at 01:26:01PM -0400, Paul Burba wrote:
>> On Tue, Sep 29, 2009 at 8:57 AM, Stefan Sperling <stsp_at_elego.de>
>>> This should be called "svn_wc__node_is_deleted" (past tense).
>>> There is a function with that name in entries.c already.
>>> The existing function expects a wc_db rather than a wc_ctx.
>>> and has a comment saying that it wants to be updated to wc_db.
>>> Looks like your new function is almost a drop-in replacement.
>> Hi Stefan,
>> libsvn_wc/entries.c:svn_wc__node_is_deleted() is actually asking
>> the 'deleted' member of svn_wc_entry_t not the 'schedule' member.
>> entry->deleted and entry->schedule == svn_wc_schedule_delete are
>> different beasts:
>> /** The directory containing this entry had a versioned child of
>> * name, but this entry represents a different revision or a
>> * path at which no item exists in the repository. This typically
>> * arises from committing or updating to a deletion of this entry
>> * without committing or updating the parent directory.
>> * The schedule can be 'normal' or 'add'. */
>> svn_boolean_t deleted;
>> /** scheduling (add, delete, replace ...) */
>> svn_wc_schedule_t schedule;
> Oh, right. Thanks for pointing that out.
> I guess the functions should contain the word "schedule" then.
> What about:
I caution you put put on your asbestos underwear before Greg gets to
The concept of "schedule" is obsolete. Done. Toast. Fini.
I suggest you *strongly* rethink anything re-adding those terms to the
Received on 2009-09-30 20:03:13 CEST