[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: [PATCH] remove svn_wc_entry_t from export.c

From: Stefan Sperling <stsp_at_elego.de>
Date: Wed, 30 Sep 2009 18:46:28 +0100

On Wed, Sep 30, 2009 at 01:26:01PM -0400, Paul Burba wrote:
> On Tue, Sep 29, 2009 at 8:57 AM, Stefan Sperling <stsp_at_elego.de> wrote:
> > This should be called "svn_wc__node_is_deleted" (past tense).
> > There is a function with that name in entries.c already.
> > The existing function expects a wc_db rather than a wc_ctx.
> > and has a comment saying that it wants to be updated to wc_db.
> >
> > Looks like your new function is almost a drop-in replacement.
>
> Hi Stefan,
>
> libsvn_wc/entries.c:svn_wc__node_is_deleted() is actually asking about
> the 'deleted' member of svn_wc_entry_t not the 'schedule' member.
>
> entry->deleted and entry->schedule == svn_wc_schedule_delete are
> different beasts:
>
> /** The directory containing this entry had a versioned child of this
> * name, but this entry represents a different revision or a switched
> * path at which no item exists in the repository. This typically
> * arises from committing or updating to a deletion of this entry
> * without committing or updating the parent directory.
> *
> * The schedule can be 'normal' or 'add'. */
> svn_boolean_t deleted;
>
> /** scheduling (add, delete, replace ...) */
> svn_wc_schedule_t schedule;

Oh, right. Thanks for pointing that out.

I guess the functions should contain the word "schedule" then.

What about:
        svn_wc__node_is_schedule_add()
        svn_wc__node_is_schedule_delete()

Stefan

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=462&dsMessageId=2402201
Received on 2009-09-30 19:46:45 CEST

This is an archived mail posted to the Subversion Dev mailing list.