[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SVN 1.4 doesn't run on Windows 2019 core

From: Neil Sleightholm <neil_at_x2systems.com>
Date: Tue, 14 Jul 2020 08:06:12 +0000

I have found the issue, it wasn't specially Windows 2019 core but could happen on any version and isn't an SVN bug. The TortoiseSVN 1.14 installer was removing libapr_tsvn.dll and libaprutil_tsvn.dll on upgrade but not a clean install, repairing the installing will fix it and according to the link below it will be fixed in patch soon.
https://stackoverflow.com/questions/62392862/missing-tortoisesvn-context-menu-after-upgrading-to-1-14-0
Neil

On 2020/07/13 15:17:07, Neil Sleightholm <n..._at_x2systems.com> wrote:
> Your operating system>
> Windows 2019 Core (Version 10.0.18363.900)>
>
> The release and/or revision of Subversion>
> svn, version 1.14.0 (r1876290)>
> compiled May 24 2020, 17:07:49 on x86-microsoft-windows>
>
> The compiler and configuration options you built Subversion with>
> Downloaded as part of TortoiseSVN>
>
> Any private modifications you made to your Subversion>
> N/A>
>
> The version of Berkeley DB you're running Subversion with, if any>
> N/A>
>
> Anything else that could possibly be relevant. Err on the side of too much information, rather than too little.>
> When you run SVN nothing happens, no error or any other output, same goes for SVN --version.>
>
> This only happens on Windows 2019 core (i.e. no UI) my guess would be that it is linked to an API that is not available in core. SVN versions 1.13 and earlier work ok.>

>
> Neil>
>
> Neil Sleightholm>
> X2 Systems Limited>
> neil_at_x2systems.com>
>
>
Received on 2020-07-14 12:32:21 CEST

This is an archived mail posted to the Subversion Users mailing list.