[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Can not build 1.14.0 python3 bindings without SWIG installed

From: Yasuhito FUTATSUKI <futatuki_at_yf.bsdclub.org>
Date: Mon, 1 Jun 2020 04:41:44 +0900

Hi,

On 2020/06/01 0:27, Lev Serebryakov wrote:
> Hello Users,
>
> Documentation says, that SWIG is optional to build Python/Perl/Ruby/Java
> bindings. I'm trying to build python bindings, with python 3.7.7
> installed, but without SWIG.
>
> I get this error:
>
> --- .swig_py_checked ---
> --- /usr/home/lev/FreeBSD/ports/devel/py-subversion/work-py37/subversion-1.14.0/subversion/bindings/swig/python/libsvn ---
> --- subversion/bindings/swig/python/svn_client.lo ---
> --- subversion/bindings/swig/python/libsvn_swig_py/swigutil_py.lo ---
> --- .swig_py_checked ---
> SWIG python disabled at configure time: SWIG version is not suitable
> *** [.swig_py_checked] Error code 1
>
> make[1]: stopped in /usr/home/lev/FreeBSD/ports/devel/py-subversion/work-py37/subversion-1.14.0
>
> Configure stage looks like this:
>
> configure: Configuring python swig binding
> checking for Python includes... -I/usr/local/include/python3.7m
> checking Python.h usability... yes
> checking Python.h presence... yes
> checking for Python.h... yes
> configure: py3c library configuration via pkg-config
> checking for py3c library... yes
> checking for compiling Python extensions... cc -pthread -fPIC
> checking for linking Python extensions... cc -pthread -shared -L/usr/local/lib -fstack-protector-strong
> checking for linking Python libraries... -L/usr/local/lib
> checking for Python >= 3... yes
> test: : bad number
> configure: WARNING: Subversion Python bindings for Python 3 require SWIG 3.0.10 or newer
> test: : bad number

We are sorry, this is a bug of configure, which is fixed in trunk but
is not back ported to 1.14.x yet.

If there is no swig executable, or there exist swig executable which version
is 3.0.10 or newer in the PATH, then it can be avoid without passing
--without-swig option to configure.

If there is swig executable in the PATH and its version is not 3.0.10 or
newer, it is need to make fake executable like:
[[[
#!/bin/sh
echo Version 3.0.12
]]]
and explicitly specify it by --with-swig=/path/to/fake-script.

Or alternatively, apply attached patch, and pass --without-swig option
to configure.

Cheers,

-- 
Yasuhito FUTATSUKI <futatuki_at_yf.bsclub.org>

Received on 2020-05-31 21:44:33 CEST

This is an archived mail posted to the Subversion Users mailing list.