[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Recommended apr / openssl etc. library version for svn ?

From: Cooke, Mark <mark.cooke_at_siemens-healthineers.com>
Date: Tue, 21 Nov 2017 15:11:51 +0000

Hello,

Is there any support for building svn with OpenSSL 1.1.0 yet? I did a search in the archives and only came up with Stefan's MaxSVN build which has so far excluded the update from 1.0.2 [1] but that was back in February?

[1] https://svn.haxx.se/dev/archive-2017-02/0145.shtml

I managed to build httpd with apr 1.6.2 and OpenSSL 1.1.0g (using `cvtdsp.pl -ossl11`) but the subversion build has 113 errors and I am wondering if this is worth persevering with?

If not, is the MaxSVN dependency list about the best recommendation?

*Apache httpd 2.4.23 (.29)
*Apache Serf(tm) 1.3.9
*APR 1.5.2 (1.6.3)
*APR-util 1.5.4 (1.6.1)
*APR iconv 1.2.1 (1.2.2)
*Expat 2.2.0 (2.2.5)
*OpenSSL 1.0.2j (.2m)
*PCRE 8.39 (8.41)
*SQLite 3.15.1 (amalgamation) (3.21)
*ZLib 1.2.8 (1.2.11)

...subject to security updates of course (brackets show latest version at time of writing)!

Thanks,

~ Mark C
Received on 2017-11-21 16:12:21 CET

This is an archived mail posted to the Subversion Users mailing list.