[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Checksum mismatch still with 1.8.19

From: Grant Drake <Grant.Drake_at_ihsmarkit.com>
Date: Tue, 29 Aug 2017 16:58:53 +0000

Our current Subversion server is 1.8.5. We are trying to setup a replacement server, on which I have installed 1.8.19.

The svnadmin load command on the 1.8.19 server for one of the repository dump files only comes up repeatedly with this error about 80% of the way through the revisions:

svnadmin: E160000: SHA1 of reps '-1 133 284 793 a21e1fc00eb3e762b9b269b65b16a7bc ac7b8b00ada08b3e6bba37a0be206ad5faab70c1 6476-4zw/_a' and '-1 641 284 793 a21e1fc00eb3e762b9b269b65b16a7bc ac7b8b00ada08b3e6bba37a0be206ad5faab70c1 6476-4zw/_a' matches (ac7b8b00ada08b3e6bba37a0be206ad5faab70c1) but contents differ
svnadmin: E160004: Filesystem is corrupt
svnadmin: E200014: Checksum mismatch while reading representation:
   expected: a21e1fc00eb3e762b9b269b65b16a7bc
     actual: ac1cc0244040d0134191ec8cec175e1f

I have run svnadmin verify on the original server repo, it shows no indication of corruption.

What can we do? Must we upgrade the original source server to 1.8.19 in order to produce a new dump file that can be loaded?

________________________________

This e-mail, including accompanying communications and attachments, is strictly confidential and only for the intended recipient. Any retention, use or disclosure not expressly authorised by Markit is prohibited. This email is subject to all waivers and other terms at the following link: http://www.markit.com/en/about/legal/email-disclaimer.page

Please visit http://www.markit.com/en/about/contact/contact-us.page for contact information on our offices worldwide.
Received on 2017-08-29 19:03:18 CEST

This is an archived mail posted to the Subversion Users mailing list.