[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Error 10179 / SVN loses authentication during session

From: Oudhuis, Robin <robin.oudhuis_at_traduco.nl>
Date: Wed, 23 Sep 2015 10:21:34 +0000

Hello,

We use SVN with a small team (3 developers), and we've been experiencing some strange issues lately. We use tortoiseSVN to connect to out repository from Windows explorer, and some of the time some of our actions get rejected, asking us to log in again. As I also received an error, perhaps these two are related. (see below for full error copy)

When actually using the provided login dialog, we never actually get access. (even checking the remember me checkbox does not solve it.) All three of our users have this issue, but not all of the time.

For example, this morning I was allowed to update to the latest versions, and perform some searches through the logs (code review). After a couple of files I suddenly got the login dialog, after which the error popped up.

Workaround:
Some of the time, I've managed to actually continue my work by resetting my password in Assembla (through the website). But that does not work consistently.

Attempts made to solve it on our end:

- Install the latest version of SVN/Tortoise

- Removing the authentication files (so Tortoise could regenerate them)

What can we do to fix this?

Kind regards,

Robin Oudhuis

---------------------------
Subversion Exception!
---------------------------
Subversion encountered a serious problem.
Please take the time to report this on the Subversion mailing list
with as much information as possible about what
you were trying to do.
But please first search the mailing list archives for the error message
to avoid reporting the same problem repeatedly.
You can find the mailing list archives at
http://subversion.apache.org/mailing-lists.html

Subversion reported the following
(you can copy the content of this dialog
to the clipboard using Ctrl-C):

In file
'D:\Development\SVN\Releases\TortoiseSVN-1.9.0\ext\subversion\subversion\libsvn_wc\wc_db.c'
line 10179: assertion failed (svn_dirent_is_absolute(local_abspath))
---------------------------
OK
---------------------------
Received on 2015-09-23 12:31:05 CEST

This is an archived mail posted to the Subversion Users mailing list.