[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svnsync: Authorization failed

From: Eric Johnson <eric_at_tibco.com>
Date: Mon, 14 Sep 2015 09:16:20 -0700

Hi Hubert,

There should be two sets of credentials you can pass to svnsync. I don't
remember what they're called for 1.6. Did you try passing the
--sync-username and --sync-password?

Eric.

On Sun, Sep 13, 2015 at 11:59 PM, Li, Hubert <Hubert.Li_at_arris.com> wrote:

> Thanks, Eric. I tried to add –username and –password in svnsync, and got
> the same error messages. Yes, 1.6.6 is old, but we have to use it for some
> reasons.
>
>
>
> Thanks,
>
> Hubert Li
>
> ARRIS
>
>
>
> *From:* Eric Johnson [mailto:eric_at_tibco.com]
> *Sent:* Monday, September 14, 2015 2:43 PM
> *To:* Li, Hubert <Hubert.Li_at_arris.com>
> *Cc:* users_at_subversion.apache.org
> *Subject:* Re: svnsync: Authorization failed
>
>
>
> Two quick thoughts (I'm not a developer, just a user of Subversion):
>
>
>
> 1) 1.6.6 is old. If you can upgrade, you might get easier to understand
> error messages.
>
>
>
> 2) The sync operation is trying to sync *from* some other place. Given
> that your credentials to access the zch124... repository may be fine, the
> likely culprit is the credentials to access the source of the sync request
> data. In any case, "svnsync help sync" will give you the command line
> options you can pass to set the creds.
>
>
>
> Eric.
>
>
>
>
>
> On Sun, Sep 13, 2015 at 8:02 PM, Li, Hubert <Hubert.Li_at_arris.com> wrote:
>
> Hi,
>
>
>
> I got the following error when I ran svnsync:
>
> [root_at_zch124svn01 conf]# svnsync sync svn://
> zch124svn01.ap.mot-mobility.com/miracle3
>
> …
>
> subversion/svnserve/serve.c:167: (apr_err=170001)
>
> svnsync: Authorization failed
>
>
>
> but I can co or export it with the same user, e.g.
>
> [/dept/stb/...67/svn/test]$ svn export svn://
> zch124svn01.ap.mot-mobility.com/miracle3
>
> A miracle3
>
> …
>
>
>
> Below is my system info:
>
> [root_at_zch124svn01 conf]# cat /etc/issue
>
> CentOS release 6.4 (Final)
>
> Kernel \r on an \m
>
>
>
> [root_at_zch124svn01 conf]# svnsync --version
>
> svnsync, version 1.6.6 (r40053)
>
> compiled Oct 24 2013, 13:59:58
>
> …
>
>
>
> BTW, we can sync it before rebooting the system, but after reboot it, we
> got this error. I start the service with this command:
>
> svnserve -d -r /svn_files/svn/
>
>
>
> Thanks,
>
> Hubert Li
>
> ARRIS
>
>
>
>
>
Received on 2015-09-14 18:16:54 CEST

This is an archived mail posted to the Subversion Users mailing list.