[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Experiencing issue where CPU is pinned at 100% - more info

From: Dave Kelsey <davek_at_gamehouse.com>
Date: Fri, 22 Nov 2013 22:29:12 +0000

Config:

OS: Windows 2012 Server 64bit
                                1TB SSD
                                8GiB RAM

Software version 4.0.2-3732.117
Subversion version 1.8.3-3732.117
Running since 11/21/2013 14:06:28 PST
Repo health Total repositories: 2 - Go to the Repositories tab to create or discover
repositories.
Throughput on primary interface 0.0 B/s IN (over about 5 minutes); 0.0 B/s OUT (over about 5 minutes)
Disk Usage as of 11/22/2013 11:10:31 PST
Used space on root volume 565.43 GB
Used space by repositories 138.65 GB
Free space on repository volume 328.81 GB
Authenticating with LDAP AD

~45 active user

We migrated Two days ago.
I dumped the repo to a new physical machine and imported it through the Web Interface.
Every day, at some point, the repository becomes inaccessible.
I RDC to the box and Apache is using 100% of the CPU. The entire machine is performing ridiculously slow.

A restart of the Service restores CPU to normal and everyone carries on until the next occurrence.

I parsed the error log for yesterday counting occurrences of all AH errors:

occurrences: DEBUG Code

545112 AH01626:
206385 AH01691:
206377 AH01697:
139630 AH01384:
        24 AH00361:
          4 AH01316:
          2 AH01320:
          2 AH01318:
          2 AH00408:
          2 AH00403:
          2 AH00348:
          2 AH00334:
          1 AH01284:
          1 AH00456:
          1 AH00455:
          1 AH00453:
          1 AH00431:
          1 AH00422:
          1 AH00418:
          1 AH00411:
          1 AH00407:
          1 AH00402:
          1 AH00391:
          1 AH00359:
          1 AH00357:
          1 AH00354:
          1 AH00352:
          1 AH00096:
          1 AH00094:

I looked at the error log unto the point of the restart. I could not see anything obvious.
I also look in the event viewer and see nothing.

Dave Kelsey
Received on 2013-11-25 11:27:36 CET

This is an archived mail posted to the Subversion Users mailing list.