[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: server config

From: Thomas Harold <thomas-lists_at_nybeta.com>
Date: Tue, 20 Aug 2013 08:51:54 -0400

On 8/19/2013 6:19 PM, Ben Reser wrote:
> On 8/19/13 9:07 AM, Scott Frankel wrote:
>> I'm new to SVN server configuration and find myself setting up a
>> CentOS 6.4 server with svn version 1.6.1, following the red-bean
>> book.
>
> I'd strongly urge you not to use 1.6.1, see the list of applicable
> security issues here: http://subversion.apache.org/security/
>
> If you're using the CentOS packages they may have patched those
> issues without updating the svn version number. You should check
> that though.
>
> If you're setting a new server I wouldn't start with 1.6.x but would
> go straight to 1.7.x or 1.8.x, probably 1.8.x if you can.

For the 1.8.1 RPMs, I suggest adding the WANDisco repository to your
configuration.

http://www.wandisco.com/subversion/download

What you're looking for is "Download Subversion Installer V1.8.1 for
Redhat". You download a shell script which then needs to be executed to
install the WANDisco repositories and install the SVN 1.8.1 RPMs.
Received on 2013-08-20 14:52:52 CEST

This is an archived mail posted to the Subversion Users mailing list.