[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Switching

From: John Maher <JohnM_at_rotair.com>
Date: Mon, 19 Aug 2013 17:31:03 +0000

Hello,

I want to thank all who have been helpful. I have gotten my test project to merge branches successfully. Now I am trying it on our production code and wish to make sure I am not making any mistakes.

I use one folder for my source code (all branches) mainly because of vendor requirements the code must be run from the same directory. I have created two branches for two new features. One feature extends an existing library. The other feature adds a new library as well as extending an existing one. When I switch I create a conflict because the directory exists in one branch and not the other:

local unversioned, incoming add upon switch

This may or may not be what is supposed to happen, that would be the first thing I would like to know. How to fix it would be the second thing that I would like to know. According to the help of the resolve command says:

So I tried svn resolve -accept working LibraryDirectory but I believe that was a mistake because then the directory was marked "Delete" which is not what I wanted. Does anyone know what is the proper response?

I did not want to lose the library from the working copy so I switched back to the other branch and then switch back. Now it says:

local delete, incoming delete upon switch

It seems I did something wrong. My next step would be to add the library back, but that may not be the best response. Any suggestions?

Thanks
JM
Received on 2013-08-19 19:32:49 CEST

This is an archived mail posted to the Subversion Users mailing list.