[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem building/packaging 1.8.0 swig bindings

From: Daniel Shahaf <danielsh_at_elego.de>
Date: Sat, 13 Jul 2013 00:38:02 +0300

Daniel J. Luke wrote on Fri, Jul 12, 2013 at 16:51:12 -0400:
> On Jul 12, 2013, at 1:02 PM, Daniel J. Luke <dluke_at_geeklair.net> wrote:
> > On Jul 12, 2013, at 12:52 PM, Daniel J. Luke <dluke_at_geeklair.net> wrote:
> >> On Jul 12, 2013, at 12:44 PM, Branko ─îibej <brane_at_wandisco.com> wrote:
> >>>
> >>> On 12.07.2013 18:14, Daniel J. Luke wrote:
> >>>> On Jul 12, 2013, at 11:44 AM, Branko ─îibej <brane_at_wandisco.com>
> >>>> wrote:
> >>>>
> >>>>> On 11.07.2013 23:11, Daniel J. Luke wrote:
> >>>>>
> >>>>>> Hello, I (co-)maintain the MacPorts subversion port (and most of the bindings ports). I haven't yet updated to 1.8.0 since the swig bindings all fail to build with gnome keyring errors (e.g. subversion/bindings/swig/python/core.c:3851:59: error: unknown type name 'svn_auth_gnome_keyring_unlock_prompt_func_t' and subversion/bindings/swig/python/core.c:3853:32: error: use of undeclared identifier 'SVN_AUTH_PARAM_GNOME_KEYRING_UNLOCK_PROMPT_FUNC')
> >>>>>>
> >>>>>> I see a thread on subversion-dev (
> >>>>>>
> >>>>>> http://svn.haxx.se/dev/archive-2013-06/0270.shtml
> >>>>>> ) about this, but no patches (yet?) and the latest nightly (r1502103) appears to have the same issue. I haven't found a patch or a bug in the subversion issue tracker (but maybe I'm just bad at searching).
> >>>>>>
> >>>>> You can regenerate the Swig wrappers, by running autogen.sh. I find that solves the problem for me on Mac OS.
> >>>>>
> >>>> Can I ask exactly what you are doing (you can pretend I'm dumb :-) )
> >>>>
> >>>> When I regen with ./autogen.sh --release, I get the same errors as before (with 1.8.0).
> >>>>
> >>>
> >>> Don't use the --release flag. That intentionally avoids regenerating the Swig wrappers. :)
> >>
> >> If I run it without --release I don't get the spew related to running swig (that I get with --release). Instead, I get swig complaining about -no-cpp-precomp (which I can track down, it shouldn't be passed to anything on any recent Mac OS X anyway...)
> >>
> >> progress (maybe)?
> >
> > ok, I got a successful build of swig-py (now to figure out how to package this up without having to add swig, python, automake, and autoconf as a dependency for all of the bindings ports...)
> >
> > I guess --release pre-generates the swig stuff while running without it has them build when I run 'make'?
>
> Just to close the loop on this, I've successfully generated patches to
> add to the MacPorts -bindings ports to make this stuff work with
> 1.8.0. Thanks for the help!

FWIW, if you run autogen anyway, you might as well build from the tag
(^/subversion/tags/1.8.0) rather than from the tarball.
Received on 2013-07-12 23:38:40 CEST

This is an archived mail posted to the Subversion Users mailing list.