[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Commit blocked by pre-commit hook (exit code 255) with no output

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Sun, 15 Apr 2012 23:02:11 +0300

Both of these look normal. Please keep the list in the CC.

Armando Perico wrote on Sun, Apr 15, 2012 at 22:00:41 +0200:
> # xxd pre-commit
> 0000000: 2321 2f62 696e 2f73 680a 6563 686f 2022 #!/bin/sh.echo "
> 0000010: 6865 6c6c 6f22 2031 3e26 3220 0a65 7869 hello" 1>&2 .exi
> 0000020: 7420 300a t 0.
>
> ls -dl testrepo/hooks/
> drwxrwxrwx. 2 apache apache 4096 Apr 15 10:56 testrepo/hooks/
>
> On Sun, Apr 15, 2012 at 5:30 PM, Daniel Shahaf <d.s_at_daniel.shahaf.name>wrote:
>
> > What's the output of
> >
> > xxd pre-commit
> > ls -dl testrepo/hooks/
> >
> > Armando Perico wrote on Sun, Apr 15, 2012 at 13:02:35 +0200:
> > > Hello,
> > >
> > > I'm having problems with hook scripts (pre-commit or post-commit)
> > > - When I try to commit, the svn commit is not performing completely, it
> > > is returning "Commit blocked by pre-commit hook (exit code 255) with no
> > > output"
> > >
> > > It passed a long while that I am trying to fix this problem without
> > > having no solution. I tried and read lots of things (here and in other
> > > places) and none seems to be working.
> > >
> > > The only answers I can find were related to the permissions of the
> > > pre-commit hook file, but I also tried all possible combinations and
> > > nothing works.
> > >
> > > These are the important information I have:
> > >
> > > pre-commit file:
> > > ----------------------
> > > #!/bin/sh
> > > echo "pre-cimmit running" 1>&2
> > > exit 0
> > > ----------------------
> > >
> > > permissions in the repository folder:
> > > drwxrwxrwx. 7 apache apache 4096 Apr 14 18:36 testrepo
> > > -rwxrwxrwx. 1 apache apache 61 Apr 14 19:26 testrepo/hooks/pre-commit
> > >
> > > when I try to commit: svn commit -m "commit log"
> > > svn: Commit blocked by pre-commit hook (exit code 255) with no output
> > > (a warning pops also when i rename to post-commit, just for
> > >
> > > apache error_log:
> > > [error] [client 127.0.0.1] Commit blocked by pre-commit hook (exit code
> > > 255) with no output. [409, #165001]
> > >
> > > OS: Fedora 16
> > >
> > > I am out of options, does anybody has a proper solution to this ?
> > > Thanks in advance
> > >
> > > -APN
> > >
> >
>
>
>
> --
> Armando Perico
Received on 2012-04-15 22:02:53 CEST

This is an archived mail posted to the Subversion Users mailing list.