[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion reports error.

From: Ryan Schmidt <subversion-2012a_at_ryandesign.com>
Date: Thu, 9 Feb 2012 17:23:32 -0600

On Feb 9, 2012, at 16:09, Alagazam.net Subversion wrote:
> On 2012-02-09 00:23, Ryan Schmidt wrote:
>> On Feb 8, 2012, at 15:41, Alagazam.net Subversion wrote:
>>
>>> On Feb 7, 2012, at 15:44, Masaru Kitajima wrote:
>>>
>>>> On 2012/02/08, at 6:36, Daniel Shahaf wrote:
>>>>
>>>>> What is the output of
>>>>>
>>>>> % ssh
>>>>> section-9_at_section-9.sakura.ne.jp
>>>>> svnserve -t
>>>>>
>>>> It is as below:
>>>>
>>>> ( success ( 2 2 ( ) ( edit-pipeline svndiff1 absent-entries commit-revprops depth log-revprops partial-replay ) ) )
>>>>
>>>> and then stops. A prompt is not shown.
>>>>
>>> This symptom of not getting any prompt back reminds me of a totally
>>> non-svn related "bug" but a network error I encountered some time ago.
>>>
>> Not seeing a prompt in this case is not a bug; it's expected behavior. svnserve is not an interactive program that has a prompt. It's a Subversion server; the above test demonstrated that svnserve is running correctly and is waiting for a Subversion client to connect to it.
>
> Maybe I was reading the threads wrong [snip]

Yes; here are the two original messages in question:

http://mail-archives.apache.org/mod_mbox/subversion-users/201202.mbox/%3c3B642053-4FF0-4BD0-A0DE-7EA55D053666@gmail.com%3e

http://mail-archives.apache.org/mod_mbox/subversion-users/201202.mbox/%3cE130C27C-FB32-453A-8F8A-830D079EAAD2@gmail.com%3e
Received on 2012-02-10 00:28:10 CET

This is an archived mail posted to the Subversion Users mailing list.