[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion reports error.

From: Masaru Kitajima <tachi.silver_at_gmail.com>
Date: Thu, 9 Feb 2012 03:41:20 +0900

Hi, Daniel

I posted e-mail below yesterday morning.

Could you find something to solve my problem?

Thanks in advance.

Kindest regards,
Masaru

On 2012/02/08, at 7:18, Masaru Kitajima wrote:
> Hi, Daniel.
>
> Thank you for your help.
>
> On 2012/02/08, at 7:00, Daniel Shahaf wrote:
>> Masaru Kitajima wrote on Wed, Feb 08, 2012 at 06:44:33 +0900:
>>> Hi, Daniel
>>>
>>> On 2012/02/08, at 6:36, Daniel Shahaf wrote:
>>>> What is the output of
>>>>
>>>> % ssh section-9_at_section-9.sakura.ne.jp svnserve -t
>>>
>>> It is as below:
>>>
>>> ( success ( 2 2 ( ) ( edit-pipeline svndiff1 absent-entries commit-revprops depth log-revprops partial-replay ) ) )
>>>
>>
>> That's expected. It confirms that the problem is client-side --- that
>> somehow your 'svn' can't execute 'ssh'.
>
> I see.
>
>> How about
>>
>> % svn info --config-option=config:tunnels:ssh=ssh svn+ssh://section-9@section-9.sakura.ne.jp/home/section-9/svn/reps
>
> Path: reps
> URL: svn+ssh://section-9@section-9.sakura.ne.jp/home/section-9/svn/reps
> Repository Root: svn+ssh://section-9@section-9.sakura.ne.jp/home/section-9/svn/reps
> Repository UUID: 58057560-1dae-0410-8c1a-ac626003657b
> Revision: 919
> Node Kind: directory
> Last Changed Author: kitajima
> Last Changed Rev: 919
> Last Changed Date: 2012-02-07 11:54:42 +0900 (火, 07 2 2012)
>
>> % ssh section-9_at_section-9.sakura.ne.jp ls /home/section-9/svn/reps
>
> README.txt
> conf
> db
> format
> hooks
> locks
>
>>> and then stops. A prompt is not shown.
>>>
>>> Kindest regards,
>>> Masaru
>>>
>>>>
>>>> ?
>>>>
>>>> Masaru Kitajima wrote on Wed, Feb 08, 2012 at 06:32:18 +0900:
>>>>> On 2012/02/08, at 6:24, Stefan Sperling wrote:
>>>>>> On Wed, Feb 08, 2012 at 06:21:27AM +0900, Masaru Kitajima wrote:
>>>>>>> I typed "echo SVN_SSH" then server says "undefined variable". And nothing found in the files you mentioned.
>>>>>>
>>>>>> To me it looks like the problem is happening on the client
>>>>>> instead of on the server.
>>>>>>
>>>>>> If you cannot find anything wrong in your ~/.subversion/config file,
>>>>>> maybe you have a bad "ssh =" option in /etc/subversion/config?
>>>>>
>>>>> Thanks again!
>>>>>
>>>>> But, I couldn't find /etc/subversion/config both on the server and the client.
>>>>> So, this may not be a problem.
>>
>> Try /usr/local/etc/subversion/config too.
>
> There's no etc directory in /usr/local in my environment.
> (I use MacBook Pro running Mac OS X 10.7.3.)
>
>>>>> <><><><><><><><><><><><><><><><><><><><><><><><><><>
>>>>> Manager / Photographer / Lecturer / Writer
>>>>> Masaru Kitajima
>>>>>
>>>>> E-mail:tachi.silver_at_gmail.com
>>>>> blog:http://www.section-9.jp/blog/bluez/
>>>>>
>>>>> <><><><><><><><><><><><><><><><><><><><><><><><><><>
>>>>>
>>>
>>> <><><><><><><><><><><><><><><><><><><><><><><><><><>
>>> Manager / Photographer / Lecturer / Writer
>>> Masaru Kitajima
>>>
>>> E-mail:tachi.silver_at_gmail.com
>>> blog:http://www.section-9.jp/blog/bluez/
>>>
>>> <><><><><><><><><><><><><><><><><><><><><><><><><><>
>
> Kindest regards,
> Masaru
>
> <><><><><><><><><><><><><><><><><><><><><><><><><><>
> Manager / Photographer / Lecturer / Writer
> Masaru Kitajima
>
> E-mail:tachi.silver_at_gmail.com
> blog:http://www.section-9.jp/blog/bluez/
>
> <><><><><><><><><><><><><><><><><><><><><><><><><><>
>

<><><><><><><><><><><><><><><><><><><><><><><><><><>
Manager / Photographer / Lecturer / Writer
Masaru Kitajima

E-mail:tachi.silver_at_gmail.com
blog:http://www.section-9.jp/blog/bluez/

<><><><><><><><><><><><><><><><><><><><><><><><><><>
Received on 2012-02-08 19:43:16 CET

This is an archived mail posted to the Subversion Users mailing list.