[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 1.7.0-alpha1 feedback

From: Stefan Sperling <stsp_at_elego.de>
Date: Tue, 21 Jun 2011 02:20:55 +0200

On Tue, Jun 21, 2011 at 02:02:08AM +0200, Uwe Schuster wrote:
> Stefan Sperling wrote:
>
> >Thanks for testing the alpha!
>
> Thanks for your feedback!
>
> >>1. Performance
> >
> >Can you set
> > http-library=neon
> >in the '[global]' section of your 'servers' configuration file
> >and see if that helps?
> >
> >The checkout finishes within 2minutes for me (with neon, on OpenBSD,
> >16mbit/s downstream).
>
> Yes this helps very much!
>
> 39 seconds and 6,82 MB instead of 30 min 27 s and 55,70 MB

Right. So this is an issue with serf.
None of the existing serf issues seem to match, though.

Is there anything special about your setup, such as connecting through a
proxy?

> >>2. APR error on checkout
> >
> >This sounds like this known issue:
> >http://subversion.tigris.org/issues/show_bug.cgi?id=3917
>
> Yes that seems to be the same issue.

Good!

> >>3. Error when the URL is "different" from the actual URL
> >
> >I can reproduce this with the externals definition in your repository:
> >
> >svn: warning: W200000: Error handling externals definition for 'jcl/source/include/jedi':
> >svn: warning: W170000: 'https://projectjedi.svn.sourceforge.net:443/svnroot/projectjedi/trunk/shared/include' isn't in the same repository as 'https://projectjedi.svn.sourceforge.net/svnroot/projectjedi'
> >Checked out revision 3547.
> >
> >This is definitely a bug.
> >It works fine if the port (:443) is removed from the externals definition.
>
> Should I log this?

I've already done so:
http://subversion.tigris.org/issues/show_bug.cgi?id=3933
Received on 2011-06-21 02:21:28 CEST

This is an archived mail posted to the Subversion Users mailing list.