[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem tagging from mixed rev working copy with a rename (copy+delete) from the past inside

From: Daniel Shahaf <d.s_at_daniel.shahaf.name>
Date: Thu, 16 Jun 2011 03:33:38 +0300

Wolfgang Röckelein wrote on Wed, Jun 15, 2011 at 10:05:16 +0200:
> Hi,
>
> I have two problems when creating a tag from a mixed rev working copy. Both
> problems are caused by a rename (copy+delete) from the past inside.
>
> One case is a directory, here I get the following error, XXXX is the deleted
> local directory path:
> Working copy not locked; this is probably a bug, please report
> svn: Directory 'XXXX' is missing
> Can't find a working copy path
> svn: Directory 'XXXX' is missing
>
> Other case is a file, here I get the following error, XXXX is the deleted file
> (relative path), YYYY is the tag path:
> Working copy is not up-to-date
> svn: Commit failed (details follow):
> svn: File 'XXXX' is out of date
> Filesystem has no item
> svn: '/svn/mobil/!svn/wrk/4263dc38-ec4c-9042-9505-c5fb37cf8ea7/YYYY/XXXX' path
> not found
>
> Can I do anything to create the tag/copy somehow? Because of the mixed rev
> working copy copying from head or a rev is not an option.
>

svnmucc, or URL-URL copy then checkout the tag and commit changes the
usual way.

> Thank you in advance,
> Wolfgang
Received on 2011-06-16 02:34:21 CEST

This is an archived mail posted to the Subversion Users mailing list.