[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Do I need to use same APR between apache and subversion?

From: Ryan Schmidt <subversion-2011a_at_ryandesign.com>
Date: Mon, 6 Jun 2011 17:01:53 -0500

On Jun 6, 2011, at 15:04, Sam Theman wrote:

> I am currently running subverison 1.6.11 with apache 2.2.15
>
> I need to go to subversion 1.6.17. So I was just going to build subversion1.6.17 svn modules and put them into the apache2 modules directory.
>
> I tried to build subversion 1.6.17 with the apr libs from apache 2.2.15 but got an error trying to build subversion. I am thinking I need to install fresh standalone apr's and then build subversion using the new standalone aprs. Will this work, or do I need to use the same apr's between apache and subversion?

Yes, you should build Apache and Subversion against the same versions of APR and APR-util. I would have thought that the versions of APR and APR-util provided with Apache should have been sufficient, then again I didn't realize Apache was being provided with any version of APR or APR-util. What error did you get? Can you upgrade APR, APR-util and Apache to the latest versions? Latest version of Apache is 2.2.19, APR is 1.4.5, APR-util is 1.3.12.
Received on 2011-06-07 00:02:38 CEST

This is an archived mail posted to the Subversion Users mailing list.