[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Common name for transaction and revision object

From: Giulio Troccoli <Giulio.Troccoli_at_uk.linedata.com>
Date: Thu, 29 Apr 2010 08:40:34 +0100

> > If you look at the svn_fs.h API, they are both referred to
> as revision roots. svn_fs_revision_root() and
> svn_fs_txn_root() both return a svn_fs_root_t * object.
> That does not sound like they're both being referred to as
> "revision roots"; that sounds like they're both being
> referred to as "roots".
> If you're just looking to name a variable, you can call it
> RevisionOrTransaction.

I'm trying to name a class that will hold information about a transaction (during pre-commit) or a revision (during post-commit). Because the information is pretty much the same, e.g path, url, files changes, log message, etc., I thought I could have a common class and then either use it in both pre- and post-commit hooks or use it as a parent class of more specialised Transaction and. Revision classes. I'm working in Perl, btw.

I'm leaning towards calling it TxnRev to be honest.


Linedata Services (UK) Ltd
Registered Office: Bishopsgate Court, 4-12 Norton Folgate, London, E1 6DB
Registered in England and Wales No 3027851 VAT Reg No 778499447
Received on 2010-04-29 09:41:11 CEST

This is an archived mail posted to the Subversion Users mailing list.