[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Update failed with "is not a working copy" message on externals

From: Giulio Troccoli <Giulio.Troccoli_at_uk.linedata.com>
Date: Wed, 3 Mar 2010 13:24:35 +0000

> The problem is that you're using file externals combined with
> putting the external locally in a directory which is not
> already a working copy. That's not supported for file externals.
>
> See
> http://svnbook.red-bean.com/nightly/en/svn.advanced.externals.html.
> Somewhere near the end it says:
>
> [[[
> Warning
>
> While directory externals can place the external directory at
> any depth, and any missing intermediate directories will be
> created, file externals must be placed into a working copy
> that is already checked out.
> ]]]

How did I miss that? ;-)

> I guess you have a couple of options:
> - use a dir external instead of a file external
> - put the file external locally directly under the current
> dir (which is already a working copy path), or in a subdir of
> which you are sure that it's already a working copy path
> - "enhance" subversion to support this :)

Thanks Johan. I had already adviced my user to put the file in an already existing directory as a workaround. I think we will stick with that.

Giulio

Linedata Services (UK) Ltd
Registered Office: Bishopsgate Court, 4-12 Norton Folgate, London, E1 6DB
Registered in England and Wales No 3027851 VAT Reg No 778499447
Received on 2010-03-03 14:25:14 CET

This is an archived mail posted to the Subversion Users mailing list.