[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "svnlook pl --revprop" does not work on transactions?

From: C. Michael Pilato <cmpilato_at_collab.net>
Date: Mon, 01 Mar 2010 13:51:08 -0500

C. Michael Pilato wrote:
> C. Michael Pilato wrote:
>> Ryan Schmidt wrote:
>>>> Did I miss something in the original problem description? Is that precisely
>>>> what is being attempted here and yet it's not working?
>>> That is my understanding:
>>>
>>> On Fri, 2010-02-26 at 22:15 -0800, Alexey Neyman wrote:
>>>> It seems that I encountered a bug in 'svnlook pl --revprop': it fails with
>>>> the following message:
>>>>
>>>> $ svnlook pl --revprop -t 10547-86b /svn/test-svn
>>>> svnlook: Invalid revision number '-1'
>>> I can replicate this error message with svn 1.6.9 on Mac OS X. "svnlook
>>> pl -t" works fine, but "svnlook pl --revprop -t" complains that revision number
>>> '-1' is invalid, though I specified a correct in-progress transaction number.
>> Okay -- sorry for the noise, then. That was my fault for not parsing the
>> conversation correctly.
>>
>> Yes, this I believe this is a bug. (I'll even grant that using an option
>> named "--revprops" does nothing for the illusion that revisions aren't
>> really just "special transactions".)
>
> I think the attached patch fixes this, and I plan to commit as much after
> some more testing.

Committed in r917640 and proposed for backport to 1.6.x.

-- 
C. Michael Pilato <cmpilato_at_collab.net>
CollabNet   <>   www.collab.net   <>   Distributed Development On Demand

Received on 2010-03-01 19:51:47 CET

This is an archived mail posted to the Subversion Users mailing list.