[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Error building Subversion 1.6.9 on Solaris 8

From: 'Stefan Sperling' <stsp_at_elego.de>
Date: Thu, 28 Jan 2010 16:04:15 +0100

On Thu, Jan 28, 2010 at 01:45:05PM +0000, Giulio Troccoli wrote:
> > The consequence is that Subversion will talk to you in
> > English only, even if your locale specifies a different language.
> > If you're comfortable with that, I guess you can disable NLS
> > as a workaround.
>
> Ok, thanks. I think we can live with that. Was this feature in 1.4.5
> already? Because I did build that without problem. I know that if it
> was I was probably using the gettext that comes with the OS and that
> was fine with 1.4.5. I would just like to know that's all.

I took a closer look.

dngettext() is GNU-specific and not portable, and our configure script
was made to use it unconditionally if NLS is enabled in r874215 on 2008-11-11.
At that point 1.5.x was already released. 1.6.x was branched on 2009-02-16
so the behaviour you are seeing is indeed new in 1.6.x.

I don't know why your linker cannot find dngettext even though you
have GNU gettext installed.

Stefan
Received on 2010-01-28 16:04:54 CET

This is an archived mail posted to the Subversion Users mailing list.