On 11/13/2009 4:05 PM, Bob Archer wrote:
> No, you are supposed to be able to use any 1.x client with any 1.x
server. However, the server may not support some of the features that
the client needs. (No I don't know what they are off hand.)
Mostly issues with sparse working copy support that was added in 1.5.
Basically, the older 1.4 server will send more data over the wire then
what the 1.5+ client actually wants.
At least that's what comes to mind when talking about servers older then
1.5. You'd have to dig through the 1.5 and 1.6 release notes for more
Compatibility with older servers
The new --depth feature naturally requires the client to be 1.5+, and
will work most efficiently if the server is also 1.5+. However, the
client will still behave correctly if the server is 1.4.x or lower;
things will just be less efficient.
This is because older servers do not understand — and therefore ignore —
what the client tells them about "depth". So when a client requests a
depth shallower than depth-infinity, older servers will send back more
data than the client wants. However, a 1.5+ client will know it's
talking to an older server and filter out this extra data. Thus,
operations may take a while, because the server sends a lot of data over
the network that the client then ignores, but the final result on the
client side will be the same. (Note that older servers understand a
recurse flag in the network protocols, and 1.5+ clients send that flag
based on the depth; this alleviates some of the extra network traffic
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-11-13 22:20:34 CET