[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svnsync not syncing repo-content

From: Marc Lustig <ml_at_marclustig.com>
Date: Thu, 15 Oct 2009 05:20:13 -0700 (PDT)

my fault ... it was simply a permission conflict.

However, I persist in my notion that the svn-command should report a warning
message stating that the permissions are not sufficient to see the contents
of the logs.

Marc Lustig wrote:
>
> OK, we finally upgraded the master-server to 1.6.5 - the mirror-server is
> still 1.6.3.
> After running the svnsync process from scratch, the same problem persists
> :-(
>
> I found out something pretty strange.
> On the mirror-server that should run the target-repo, running svn against
> the master-server reveils empty revisions for some, but not all repos:
>
> svn log -r 0:HEAD svn://mastersvn/repo
>
> ------------------------------------------------------------------------
> r1 | (no author) | (no date) | 1 line
>
>
> ------------------------------------------------------------------------
> r2 | (no author) | (no date) | 1 line
>
>
> ------------------------------------------------------------------------
> r3 | (no author) | (no date) | 1 line
>
> ........... all is empty.
>
>
> Running the same command on ANY other machine reveils the correct
> information.
>
> What might be broken on the mirror-machine?
> What might be the reason that some repos show the proper logs and some
> not?
> I just upgraded svn (client+server) yesterday to 1.6.5 using collabnet's
> RPM.
> And, most of all, why does the svn-command not report any warning or
> error-message?
>
>
>
>
>
> Nico Kadel-Garcia-2 wrote:
>>
>> On Fri, Sep 4, 2009 at 5:04 AM, Marc Lustig <ml_at_marclustig.com> wrote:
>>> Hi,
>>>
>>> we mirror a bunch of repos using svnsync 1.5.2 - remote SVN is 1.6.3
>>
>> Is there any reason not to update your svnsync to 1.6.x, perferably
>> 1.6.5? A number of very useful fixes and features have been added. It
>> seems conceivable that you've run into a backwards compatibility
>> issue.
>>
>>> All repos are reported by svnsync to be mirrored fine, like
>>>
>>> Revision xx übertragen.
>>> Eigenschaften für Revision xx kopiert.
>>> (german)
>>>
>>> However, some mirroed repos have the following status:
>>> - revision number is the same like on the master repo
>>> - content for each revision is EMPTY
>>>
>>> I repeated the sync-process several times from scratch (deleting the
>>> repo,
>>> createing new one, svn init, svn sync) - all the time the same result
>>> for
>>> those particular repos.
>>>
>>> I copied hooks/pre-revprop-change.tmpl to hooks/pre-revprop-change.
>>>
>>> The init command is as follow:
>>> svnsync --source-username svnsync --source-password xxx --sync-username
>>> svnsync --sync-password xxx --non-interactive init
>>> svn://localhost/commons
>>> svn://svn/commons
>>>
>>> The sync command looks like this:
>>> svnsync --source-username svnsync --source-password xxx --sync-username
>>> svnsync --sync-password xxx --non-interactive init
>>> svn://localhost/commons
>>> svn://svn/commons
>>>
>>>
>>> Anybody having an idea what is going wrong here?
>>> Especially I wonder why svsync reports correct operation - while it is
>>> not
>>> transfering the contents of the repo. Is svnsync a crap ?
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/svnsync-not-syncing-repo-content-tp25290738p25290738.html
>>> Sent from the Subversion Users mailing list archive at Nabble.com.
>>>
>>> ------------------------------------------------------
>>> http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2390955
>>>
>>> To unsubscribe from this discussion, e-mail:
>>> [users-unsubscribe_at_subversion.tigris.org].
>>>
>>
>> ------------------------------------------------------
>> http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2391107
>>
>> To unsubscribe from this discussion, e-mail:
>> [users-unsubscribe_at_subversion.tigris.org].
>>
>>
>
>

-- 
View this message in context: http://www.nabble.com/svnsync-not-syncing-repo-content-tp25290738p25907574.html
Sent from the Subversion Users mailing list archive at Nabble.com.
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2407863
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-10-15 14:21:36 CEST

This is an archived mail posted to the Subversion Users mailing list.