[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bizarre swig-pl build problem

From: John Beranek <john_at_redux.org.uk>
Date: Sat, 10 Oct 2009 09:42:25 +0100

[Cross-posted into users@ as there was no reply in dev@]

I'm trying to compile a reasonably fresh version of Subversion for a
Fedora Core 6 machine. My route to doing this has been to download the
Rpmforge SRPM for Red Hat Enterprise 5 and try to rebuild it.

I've now tried both 1.5.6 and 1.6.5, and both fail on a bizarre linkage
problem inside the Perl swig bindings. Seeing as the particular thing I
want from this build are the Perl bindings this is quite a problem.

The link problem manifests as below[1], I've wrapped the lines for
clarity. The issue is that no -L specifier is created for the
"subversion/bindings/perl/libsvn_swig_perl/.libs directory.

Now I can read from the subversion/bindings/swig/perl/native/Makefile.PL
file that "$swig_builddir/perl/libsvn_swig_perl/.libs" is indeed added
to the lists of paths. Equally this path ends up as a _comment_ about
the MakeMaker parameters in the generated Makefiles. However, the
EXTRALIBS and LDLOADLIBS don't end up with the path, for some reason.

What I've since found is that if I go into the failed build and re-run
"perl Makefile.PL", the Makefiles are generated correctly. What could be
  causing the path to disappear from the generated Makefiles!?

Yours questioningly,

John.

[1]
gcc -shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions
-fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386
-mtune=generic -fasynchronous-unwind-tables -L/usr/local/lib
svn_client.o -o blib/arch/auto/SVN/_Client/_Client.so \
        
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_client/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_delta/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_fs/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_ra/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_repos/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_wc/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_diff/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_subr/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_ra_local/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_ra_svn/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_ra_neon/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_fs_base/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_fs_util/.libs
-L/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/libsvn_fs_fs/.libs
-lsvn_client-1 -lsvn_delta-1 -lsvn_fs-1 -lsvn_ra-1 -lsvn_repos-1
-lsvn_wc-1 -lsvn_diff-1 -lsvn_subr-1 -lsvn_swig_perl-1 \
        
/usr/bin/ld: cannot find -lsvn_swig_perl-1
collect2: ld returned 1 exit status
make[2]: *** [blib/arch/auto/SVN/_Client/_Client.so] Error 1
make[2]: Leaving directory
`/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/bindings/swig/perl/native'
make[1]: *** [modules] Error 2
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory
`/export/home/beranej1/rpmbuild/BUILD/subversion-1.5.6/subversion/bindings/swig/perl/native'
make: *** [swig-pl] Error 2

-- 
John Beranek                         To generalise is to be an idiot.
http://redux.org.uk/                                 -- William Blake
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2405812
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-10-10 10:43:47 CEST

This is an archived mail posted to the Subversion Users mailing list.